ALGORITMOS E ESTRUTURA DE DADOS


Com relação aos vetores, vimos que estes são de grande utilizade quando surgem uma quantidade considerável de entrada de dados. O pseudocódigo abaixo refere-se algoritmo para calcular a média através de um vetor, dando entrada de 4 notas. Com base no que foi abordado sobre vetores em algoritmos, analise às afirmações.


Var
     _______________________________________
     soma,media: real
     i: inteiro
Inicio
          soma <- 0
         ____________________________________
                se i=0 entao
                     escreva(Digite a primeira nota: )
                senao
                          se i=1 entao
                                 escreva(Digite a segunda nota: )
                         senao
                                   se i=2 entao
                                              escreva(Digite a terceira nota: )
                                   senao
                                              escreva(Digite a quarta nota: )
                                   fimse
                          fimse
                fimse
               ________________________________
               ________________________________
         fimpara
         media <- soma/4
         escreval(A média encontrada é de: ,media)
Fimalgoritmo

I - Na linha 2, para declararmos a variável numeros, temos que digitar a linha de comando numeros: vetor [1-4] de real.
II - Na linha 7, a linha de comando a ser digitada com relação a estrutura de repetição será: Para i de 0 ate 3 faca.
III - Na linha 21, a linha de comando a ser digitada será: leia(numeros[i])
IV - Na linha 22, a linha de comando a ser digitada será: soma = soma + numeros(i)

É CORRETO apenas o que se afirma em:

Apenas as sentenças II e III são verdadeiras.
Apenas a sentença IV é verdadeira.
Apenas as sentenças III e IV são verdadeiras.
Apenas as sentenças I e IV são verdadeiras.
Apenas a sentença I é falsa.
Como sabemos, às propriedades dos triângulos são utilizadas para determinar os tipos existentes: equilátero, quando possui os três lados com medidas iguais - isósceles, quando possui dois lados com medidas iguais e finalmente, escaleno  quando possui os três lados com medidas diferentes. Baseado nestas informações e também sobre o que foi abordado sobre estruturas condicionais, observe o pseudocódigo abaixo, e depois responda a questão.


Algoritmo propriedades do triângulo
Var
    x,y,z:inteiro
Inicio
     escreva (Informe a medida do primeiro lado: )
     leia(x)
     escreva (Informe a medida do segundo lado: )
     leia(y)
     escreva (Informe a medida do terceiro lado: )
    leia(z)
    se((x<>0) e (y<>0) e (z<>0)) entao
          se((x+y>z) e (x+z>y) e (y+z>x)) entao
               se ((x<>y) e (x<>z) e (y<>z)) entao
                          escreva(O triângulo é escaleno)
               senao
                          se((x=y) e (y=z)) entao
                                     escreva(O triângulo é equilátero)
                          senao
                                     escreva(O triângulo é isóceles)
                         fimse
               fimse
     senao
               escreva(Os valores não permitem formar um triângulo)
     fimse
fimse
Fimalgoritmo

I - A estrutura condicional apresentada pelo algoritmo é do tipo encadeada.
II - A linha 12, não representa um teste de condição para verificar se os valores fornecidos permitem a criação de um triângulo
III - Para o triângulo ser considerado escaleno, teremos que inserir na linha 13 a condição:  se ((x<>y) ou (x<>z) ou (y<>z)).
IV - Para o triângulo ser considerado equilátero, teremos que inserir na linha 16 a condição: se((x=y) ou (y=z))

É CORRETO apenas o que se afirma em:

Apenas a sentença III é falsa.
Apenas as sentenças I e IV são verdadeiras.
Apenas a sentença II é falsa.
Apenas as sentenças I e II são verdadeiras.
Apenas a sentença I é verdadeira.
Com relação aos vetores, vimos que estes são de grande utilizade quando surgem uma quantidade considerável de entrada de dados. O pseudocódigo abaixo refere-se algoritmo para calcular a média através de um vetor, dando entrada de 4 notas. Com base no que foi abordado sobre vetores em algoritmos, analise às afirmações.


Var
     _______________________________________
     soma,media: real
     i: inteiro
Inicio
          soma <- 0
         ____________________________________
                se i=0 entao
                     escreva(Digite a primeira nota: )
                senao
                          se i=1 entao
                                 escreva(Digite a segunda nota: )
                         senao
                                   se i=2 entao
                                              escreva(Digite a terceira nota: )
                                   senao
                                              escreva(Digite a quarta nota: )
                                   fimse
                          fimse
                fimse
               ________________________________
               ________________________________
         fimpara
         media <- soma/4
         escreval(A média encontrada é de: ,media)
Fimalgoritmo

I - Na linha 2, para declararmos a variável numeros, temos que digitar a linha de comando numeros: vetor [1-4] de real.
II - Na linha 7, a linha de comando a ser digitada com relação a estrutura de repetição será: Para i de 0 ate 3 faca.
III - Na linha 21, a linha de comando a ser digitada será: leia numeros(i)
IV - Na linha 22, a linha de comando a ser digitada será: soma = soma + numeros(i)

É CORRETO apenas o que se afirma em:

Apenas as sentenças II e III são verdadeiras.
Todas as sentenças são falsas.
Apenas a sentença IV é falsa.
Apenas a sentença IV é verdadeira.
Apenas a sentença II é verdadeira.
Com relação aos vetores, vimos que estes são de grande utilizade quando surgem uma quantidade considerável de entrada de dados. O pseudocódigo abaixo refere-se algoritmo para calcular a média através de um vetor, dando entrada de 4 notas. Com base no que foi abordado sobre vetores em algoritmos, analise às afirmações.


Var
     _______________________________________
     soma,media: real
     i: inteiro
Inicio
          soma <- 0
         ____________________________________
                se i=0 entao
                     escreva(Digite a primeira nota: )
                senao
                          se i=1 entao
                                 escreva(Digite a segunda nota: )
                         senao
                                   se i=2 entao
                                              escreva(Digite a terceira nota: )
                                   senao
                                              escreva(Digite a quarta nota: )
                                   fimse
                          fimse
                fimse
               ________________________________
               ________________________________
         fimpara
         media <- soma/4
         escreval(A média encontrada é de: ,media)
Fimalgoritmo

I - Na linha 2, para declararmos a variável numeros, temos que digitar a linha de comando numeros: vetor [1-4] de real.
II - Na linha 7, a linha de comando a ser digitada com relação a estrutura de repetição será: Para i de 1 ate 4 faca.
III - Na linha 21, a linha de comando a ser digitada será: leia(numeros[i])
IV - Na linha 22, a linha de comando a ser digitada será: soma = soma + numeros(i)

É CORRETO apenas o que se afirma em:

Apenas as sentenças II e IV são verdadeiras.
Apenas a sentença II é falsa.
Apenas a sentença I é verdadeira.
Apenas as sentenças I e III são verdadeiras.
Apenas a sentença III é verdadeira.
Como vimos, em um algoritmo às estruturas condicionais permitem uma tomada de decisão. O algoritimo abaixo, foi feito no aplicativo visualog. O mesmo, tem como objetivo retornar resposta de que o valor digitado é um número ímpar ou par. Com base nesta informação, analise às opções abaixo:


1 Algoritmo terceiro algoritmo

2 Var

3     valor: ______________

4 Inicio

5     escreva(Digite um valor:)

6     leia(valor)

7     se ____________ Entao

8    escreva(O valor digitado é um número ímpar!)

9       __________

10       escreva(O valor digitado é um número par!)

11    fimse

12 Fimalgoritmo

I - Na linha 3 iremos declarar a variável valor como sendo inteiro.
II - Na linha 7 substituiremos às interrogações por ((valor mod 2)=1).
III - Na linha 9 substituiremos às interrogações por senao.
IV - A estrutura de seleção utilizada no algoritmo é denominada de seleção composta.

É CORRETO apenas o que se afirma em:

Todas as sentenças são verdadeiras.
Apenas as sentenças I e III são verdadeiras.
Apenas a sentença I é verdadeira.
Apenas a sentença III é verdadeira.
Todas as sentenças são falsas.
Em algoritmos, vimos que uma estrutura de seleção permite a escolha de um grupo de ações, também conhecidas como bloco, a serem perguntadas quando determinadas condições respresentadas por expressões lógicas ou relacionais, são ou não satisfeitas. Com base nesta informação, analise às afirmações abaixo:

I - A seleção simples (se-então), não pode ser utilizada quando há a necessidade de testar certa condição antes de executar uma determinada ação.
II - A seleção composta (se-então-senão), é utilizada quando temos dois conjuntos de instruções a serem realizados de acordo com a avaliação da condição: um conjunto que será executado quando a condição resultar verdadeiro e outro para resultado falso.
III - Na seleção encadeada, também conhecida como seleção aninhada, ocorre quando determinada ação ou bloco deve ser executado se apenas uma possibilidade ou combinação for satisfeito.
IV - A seleção de múltipla escolha, não pode ser detectada quando uma estrutura de seleção funciona como um conjunto de opções para escolha.

É CORRETO apenas o que se afirma em:

Apenas a sentença II é verdadeira.
Apenas a sentença I é falsa.
Apenas as sentenças I e II são verdadeiras.
Todas as sentenças são verdadeiras.
Apenas a sentença IV é verdadeira.
Como sabemos, às propriedades dos triângulos são utilizadas para determinar os tipos existentes: equilátero, quando possui os três lados com medidas iguais - isósceles, quando possui dois lados com medidas iguais e finalmente, escaleno  quando possui os três lados com medidas diferentes. Baseado nestas informações e também sobre o que foi abordado sobre estruturas condicionais, observe o pseudocódigo abaixo, e depois responda a questão.


Algoritmo propriedades do triângulo
Var
    x,y,z:inteiro
Inicio
     escreva (Informe a medida do primeiro lado: )
     leia(x)
     escreva (Informe a medida do segundo lado: )
     leia(y)
     escreva (Informe a medida do terceiro lado: )
    leia(z)
    se((x<>0) e (y<>0) e (z<>0)) entao
          se((x+y>z) e (x+z>y) e (y+z>x)) entao
               se ((x<>y) e (x<>z) e (y<>z)) entao
                          escreva(O triângulo é escaleno)
               senao
                          se((x=y) e (y=z)) entao
                                     escreva(O triângulo é equilátero)
                          senao
                                     escreva(O triângulo é isóceles)
                         fimse
               fimse
     senao
               escreva(Os valores não permitem formar um triângulo)
     fimse
fimse
Fimalgoritmo

I - A estrutura condicional apresentada pelo algoritmo é do tipo encadeada.
II - A linha 12, representa um teste de condição para verificar se os valores fornecidos permitem a criação de um triângulo
III - Para o triângulo ser considerado escaleno, teremos que inserir na linha 13 a condição:  se ((x<>y) ou (x<>z) ou (y<>z)).
IV - Para o triângulo ser considerado equilátero, teremos que inserir na linha 16 a condição: se((x=y) ou (y=z))

É CORRETO apenas o que se afirma em:

Apenas a sentença II é falsa.
Apenas as sentenças I e II são verdadeiras.
Apenas a sentença III é falsa.
Apenas a sentença I é verdadeira.
Apenas as sentenças I e III são verdadeiras.
Como vimos, em um algoritmo às estruturas condicionais permitem uma tomada de decisão. O algoritimo abaixo, foi feito no aplicativo visualog. O mesmo, tem como objetivo retornar resposta de que o valor digitado é um número ímpar ou par. Com base nesta informação, analise às opções abaixo: 1 Algoritmo terceiro algoritmo 2 Var 3     valor: ______________ 4 Inicio 5     escreva(Digite um valor:) 6     leia(valor) 7     se ____________ Entao 8    escreva(O valor digitado é um número ímpar!) 9       __________ 10       escreva(O valor digitado é um número par!) 11    fimse 12 Fimalgoritmo I - Na linha 3 iremos declarar a variável valor como sendo caractere. II - Na linha 7 substituiremos às interrogações por ((valor mod 2)=2). III - Na linha 9 substituiremos às interrogações por entao. IV - A estrutura de seleção utilizada no algoritmo é denominada de seleção simples. É CORRETO apenas o que se afirma em:

Apenas as sentenças II e III são verdadeiras.
Todas as sentenças são falsas.
Todas as sentenças são verdadeiras.
Apenas as sentenças I e II são verdadeiras.
Apenas a sentença I é verdadeira.
Como vimos, em um algoritmo às estruturas condicionais permitem uma tomada de decisão. O algoritimo abaixo, foi feito no aplicativo visualog. O mesmo, tem como objetivo retornar resposta de que o valor digitado é um número ímpar. Com base nesta informação, analise às opções abaixo. Algoritmo Primeiro Algoritmo Var valor: inteiro Inicio escreva(Digite um valor:) leia(valor) __________________ Entao escreva(O valor digitado é ímpar!) _______ Fimalgoritmo Algoritmo Segundo Algoritmo Var valor: inteiro Inicio escreva(Digite um valor:) leia(valor) __________________ Entao escreva(O valor digitado é par!) _______ Fimalgoritmo I - A estrutura condicional que foi utilizada no algorítmo foi um SE composta II - Na sétima linha do primeiro algoritmo utilizaremos a linha de comando  se ((valor mod 2)=0) para a condição ser um número ímpar. III - Na sétima linha do segundo algoritmo utilizaremos a linha de comando  se ((valor mod 2)=1) para a condição ser um número par. IV - Tanto para o primeiro como para o segundo algoritimo, teremos que finalizar a estrutura condicional SE, inserindo na nona linha o comando fimse É CORRETO apenas o que se afirma em:

Apenas as sentenças II e IV são verdadeiras.
Apenas as sentenças II e III são verdadeiras.
Apenas a sentença III é verdadeira.
Apenas as sentenças I e IV são verdadeiras.
Apenas a sentença IV é verdadeira.
Como sabemos, às propriedades dos triângulos são utilizadas para determinar os tipos existentes: equilátero, quando possui os três lados com medidas iguais - isósceles, quando possui dois lados com medidas iguais e finalmente, escaleno  quando possui os três lados com medidas diferentes. Baseado nestas informações e também sobre o que foi abordado sobre estruturas condicionais, observe o pseudocódigo abaixo, e depois responda a questão.Algoritmo propriedades do triânguloVar    x,y,z:inteiroInicio     escreva (Informe a medida do primeiro lado: )     leia(x)     escreva (Informe a medida do segundo lado: )     leia(y)     escreva (Informe a medida do terceiro lado: )    leia(z)    se((x<>0) e (y<>0) e (z<>0)) entao          se((x+y>z) e (x+z>y) e (y+z>x)) entao               se ((x<>y) e (x<>z) e (y<>z)) entao                          escreva(O triângulo é escaleno)               senao                          se((x=y) e (y=z)) entao                                     escreva(O triângulo é equilátero)                          senao                                     escreva(O triângulo é isóceles)                         fimse               fimse     senao               escreva(Os valores não permitem formar um triângulo)     fimsefimseFimalgoritmo I - A estrutura condicional apresentada pelo algoritmo é do tipo composta. II - A linha 12, representa um teste de condição para verificar se os valores fornecidos permitem a criação de um triângulo III - Para o triângulo ser considerado escaleno, teremos que inserir na linha 13 a condição:  se ((x<>y) ou (x<>z) ou (y<>z)). IV - Para o triângulo ser considerado equilátero, teremos que inserir na linha 16 a condição: se((x=y) e (y=z)) É CORRETO apenas o que se afirma em:

Apenas as sentenças II e IV são verdadeiras.
Apenas a sentença I é verdadeira.
Apenas a sentença I é falsa.
Apenas as sentenças I e IV são verdadeiras.
Apenas a sentença IV é verdadeira.
Páginas: 12345678910